Honda TRX700XX Forum - Club700XX banner
1 - 8 of 8 Posts

·
Registered
Joined
·
323 Posts
Discussion Starter · #1 ·
On your 700XX with the clutch freeplay properly adjusted where does the clutch feel like it's beginning to grab or go over the center point? I'm speaking about how far in the clutch lever's travel the bike begins to have solid movement.

thanks
 

·
Registered
Joined
·
323 Posts
Discussion Starter · #3 ·
I'm most interested in where the bike starts moving solidly forward, not so much when it starts to engage. I hope this makes sense. The quad I bought had the clutch mis-adjusted so there was zero free play and in fact may have been slipping very little, but enough to cause a long engagement condition now. Not a huge deal to swap out the plates, but I'm curious what others report.

thanks
 

·
Registered
Joined
·
323 Posts
Discussion Starter · #4 ·
No one else has any input here? I'd appreciate some thoughts before I tear into the clutch on this thing.

thanks
 

·
Premium Member
Joined
·
561 Posts
i will be able to help you out in a couple of hours. i am watching my son today so i cant just take off on my quad while turning loose a 6 month old in my house. Or Can I??????? hmmmmmmmmm
 

·
Premium Member
Joined
·
561 Posts
hey bro sorry its late but i just took the bike for a spin. it seems like it starts grabbing a 1/4 of the way and is totally engaged a little over half way hope this helps.
 

·
Registered
Joined
·
201 Posts
i think its more of a rider specific thing...

one rider likes his/her clutch to grab right off the handle bar while another likes it to be out on the lever. as long as it fully releases (clutch fully engaging) with a little free play you are good to go anywhere inbetween :D
 

·
Registered
Joined
·
323 Posts
Discussion Starter · #8 ·
hey bro sorry its late but i just took the bike for a spin. it seems like it starts grabbing a 1/4 of the way and is totally engaged a little over half way hope this helps.
Thanks...mine was just horribly out of adjustment. I took it apart, cleaned the pivot points, lubed the cable and adjusted it properly and now it works right off the bar. Much better. Actually got the parking break all adjusted and working now also.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top