Honda TRX700XX Forum - Club700XX banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
My TRX 700 does not want to start after switching the ignition off at the end of my last ride. When switching the ignition on, all the lights on the dash flikkers dimly and a continous klikking sound originates fron the front lower end of the petrol tank where the electronic control units are located. The battery voltage is fine and all the fuses are fine. I have tried to tow start it without success. The main lights also does not work when switching it on, it seems that no power is delivered anywhere. I have also checked and cleaned the battery terminals.

I have traced the electrical system and the klikking sound originates from the angular control unit that cuts engine power in case of a roll. I have rolled the quad some time ago but it was running fine till now. Is this indication that the angular control unit requires replacement?
 

·
Premium Member
Joined
·
2,932 Posts
My TRX 700 does not want to start after switching the ignition off at the end of my last ride. When switching the ignition on, all the lights on the dash flikkers dimly and a continous klikking sound originates fron the front lower end of the petrol tank where the electronic control units are located. The battery voltage is fine and all the fuses are fine. I have tried to tow start it without success. The main lights also does not work when switching it on, it seems that no power is delivered anywhere. I have also checked and cleaned the battery terminals.
You've got a bad connection, It's sounds like while you were riding you lost power from the battery and was running off the alternator. Pull the power and ground off the battery and make sure it's clean and tighten them back, Check the wiring is secure in the crimps also.
 

·
Premium Member
Joined
·
288 Posts
I might be way off in left field, but have you tried centering the red switch on the left handle bar to "run"??? lol
 
1 - 3 of 3 Posts
Top