Honda TRX700XX Forum - Club700XX banner
1 - 5 of 5 Posts

·
Registered
Joined
·
80 Posts
I have had them for about four months. They are loud when clean; holy vibrations bat man loud. But when they get just a bit of mud, they quit. I honestly think it is the mud build up in the foot peg channel that keeps it down. It hasn't rained here in over a month or so, so no mud, but if it works I may just fill it with silicone.

All that being said, I didn't notice too much mud build up, and I liked the fact that I had "other" locations to put my feet while riding, and that no sticks come up. Others have made comments about potential mud build up.

They are not easy to put on, do not tighten anything until you get all the bolts in and they haves no instructions. But overall, I like them.
 

·
Premium Member
Joined
·
1,888 Posts
I also have the PRM side bars in black... And YES, you do get an echo from your motor off the side bars at certain RPMs and at first, that can be un-nerving. But, you get used to it rather quickly. It can sound like there's another quad right behind you... like in 3rd gear. One thing I've noticed recently is that when I added my Barker exhaust, the echo is gone... Or perhaps just buried behind the louder exhaust. One note... You'll probably have to move your shifter lever up one spline to get you foot under it to shift.. Not a big deal and is easy to do... and you'd get used to the new position quickly.

Thats right, someone wanted pictures... OK, stand by, let me get my camera and I'll be right back......
OK, I'm back... Ya still there? Here you go. Sorry, didn't want to roll my quad out of the garage. Besides, there was a truck in the way and didn't want to move it either.

roadkill
 

·
Registered
Joined
·
80 Posts
Yeah, I forgot about the shift lever. It was awkward at first, but I got used to it quickly. I would have posted pictures, but RoadKill replied first. Of course, mine looks the same except its that faster red color. :tup:
 
1 - 5 of 5 Posts
Top