Honda TRX700XX Forum - Club700XX banner
1 - 7 of 7 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
Seems everytime I hammer it and let out, it puffs white smoke. Not really losing any coolant nor does it smoke under throttle. Normal or should i let the stealership check it out? Quad only has about 30 hours or so on it!

Only mods are uni filter and EHS lid
 

·
Premium Member
Joined
·
2,189 Posts
DEF sounds like too much oil in the filter. I would just take the filter off and pat it dry on the inside and out to get any excess oil out. Then pull your plug and clean it/replace it (that way if it keeps smoking you can check the plug). if it was regular oil it'd be more blue, trust me I KNOW lmao. Also, just check to make sure your engine oil level is good.
 

·
Registered
Joined
·
2,293 Posts
sounds like you still have water in your oil:atv::xx:
 

·
Premium Member
Joined
·
4,835 Posts
Seems everytime I hammer it and let out, it puffs white smoke. Not really losing any coolant nor does it smoke under throttle. Normal or should i let the stealership check it out? Quad only has about 30 hours or so on it!

Only mods are uni filter and EHS lid
Did you fit a EFI programmer ?
 

·
Super Moderator
Joined
·
5,866 Posts
Seems everytime I hammer it and let out, it puffs white smoke. Not really losing any coolant nor does it smoke under throttle. Normal or should i let the stealership check it out? Quad only has about 30 hours or so on it!

Only mods are uni filter and EHS lid
Did you fit a EFI programmer ?
:funny: Ru really replying to a almost 3 year help post? I'd hope he figured it out by now... :lmao:

Just messing with you, and I know it wasn't you that woke the dead thread...
 
1 - 7 of 7 Posts
Top