Club700XX - Honda TRX700XX Forum - Reply to Topic
Thread: Vibration/Rattle in front of engine Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
 
 

Register Now



In order to be able to post messages on the Club700XX - Honda TRX700XX Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-15-2009 12:48 PM
scuzz In the other forum they were making a big deal about how they take car of their customers, do you feel like they've looked out for you?



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
06-15-2009 12:41 PM
xx-rated It's not really the part or the material, the welds just suck. Actually, the design is a little shitty too. But if the welds were good, the aluminum would have cracked before the welds did. If I had known that Pro Armor was outsourcing their stuff to China, I would not have bought anything from them. FWIW, the nerfs are holding together just fine (knock on wood!).
06-15-2009 09:58 AM
THREESVTS I have a feeling it's because most manufactures are using cheaply made Chinese made parts.
06-15-2009 09:41 AM
xx-rated
Quote:
Originally Posted by Killer_Shee View Post
I had the same problem after my last ride, and investigation showed that the welds on the lower mount on my Pro Armor bumper had broken completely loose. I see that even DG is having this problem. I am wondering if there isn't some flex in the frame that is causing this since it seems to be a problem with all the bumper and not just Pro Armor.
Well, I figured it out this weekend as the vibbrating got worse and worse. Same thing here, both the welds on the Pro Armor bumper broke at the corners. They look like very poor welds, and I'll have my friend weld them back together. It is kind of strange how many people are experiencing this problem, even with different manufacturers of the bumper. I'm sending the pics to Pro Armor today.
06-05-2009 03:13 PM
scuzz Post Pics!



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
06-05-2009 06:27 AM
THREESVTS I always use loctite on all bolts on my ATV's. I do not think that is the cure. Products are getting so cheaply made now a days and any flex they have is exaggerated with the vibrations and abuse they go through with normal trail riding. I'm thinking about just making my own bumper modeled after my Pro XC bumper. Should be very easy to do.
06-04-2009 10:35 PM
msg harmon Loctite is great but I hope you all are using the blue loctite. If not you will have to use your wifes hair dryer to heat the nuts and bolts up a little to get them loose. Just a little tid bid there. Blue will work just fine and you will get the bolts loose when you need to.
06-04-2009 08:09 AM
Chrisj
Quote:
Originally Posted by Killer_Shee View Post
I had the same problem after my last ride, and investigation showed that the welds on the lower mount on my Pro Armor bumper had broken completely loose. I see that even DG is having this problem. I am wondering if there isn't some flex in the frame that is causing this since it seems to be a problem with all the bumper and not just Pro Armor.
This is what I think too. AC's does the same.
06-04-2009 07:14 AM
Killer_Shee I had the same problem after my last ride, and investigation showed that the welds on the lower mount on my Pro Armor bumper had broken completely loose. I see that even DG is having this problem. I am wondering if there isn't some flex in the frame that is causing this since it seems to be a problem with all the bumper and not just Pro Armor.
05-28-2009 04:46 PM
wv700xxrider
Quote:
Originally Posted by hondarider203 View Post
i had that as well turns out that my brannew dg front bumper mount cracked... this is horse s#!+

my DG bumper broke the bottom bracket. It makes all kinds of noise.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome